2004 Idling rough and throwing O2 code and misfire code - MY350Z.COM Forums



Reply
 
 
 
Thread Tools Search this Thread
Old 03-14-2017, 05:51 AM   #1
ChristopherE
Registered User
Thread Starter
 
Join Date: Mar 2017
Location: Georgia
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default 2004 Idling rough and throwing O2 code and misfire code

Hey guys my car has thrown two codes. The Multiple Misfire and and O2 sensor code. It has a rough idle and this morning was hard to start. The car was stuttering when I went to take off from a stop sign this morning as well. My friend was driving behind me and said that black smoke was poofing out the exhaust, but that's unburnt fuel that is laying the misfiring cylinders. Any help would be greatly appreciated. Thanks guys.
ChristopherE is offline   Reply With Quote
Old 03-14-2017, 06:33 AM   #2
travlee
Master
iTrader: (8)
 
travlee's Avatar
 
Join Date: Jul 2011
Location: Texas
Posts: 29,905
Thanked 4,152 Times in 2,720 Posts
Default

Quote:
Originally Posted by ChristopherE View Post
Hey guys my car has thrown two codes. The Multiple Misfire and and O2 sensor code. It has a rough idle and this morning was hard to start. The car was stuttering when I went to take off from a stop sign this morning as well. My friend was driving behind me and said that black smoke was poofing out the exhaust, but that's unburnt fuel that is laying the misfiring cylinders. Any help would be greatly appreciated. Thanks guys.
what, if anything, have you done to resolve the issue you are having?
travlee is offline   Reply With Quote
Old 03-14-2017, 07:11 AM   #3
ChristopherE
Registered User
Thread Starter
 
Join Date: Mar 2017
Location: Georgia
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've been trying to problem solve by readings lots of forums but I plan on taking the cats off and checking them. It does have high flow cars, but they might be cheap ones. I've messed with the o2 sensor harness and it took the light off but I've never know the o2 sensor to make a cylinder misfire.
ChristopherE is offline   Reply With Quote
Old 03-14-2017, 07:13 AM   #4
travlee
Master
iTrader: (8)
 
travlee's Avatar
 
Join Date: Jul 2011
Location: Texas
Posts: 29,905
Thanked 4,152 Times in 2,720 Posts
Default

you prob have some bad coil packs
travlee is offline   Reply With Quote
Old 03-14-2017, 07:49 AM   #5
ChristopherE
Registered User
Thread Starter
 
Join Date: Mar 2017
Location: Georgia
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

What do the coil packs need to read cranking over?
ChristopherE is offline   Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -8. The time now is 08:12 PM.


Copyright 2002 - 2008, MY350Z.COM All Rights Reserved.