Notices
2003-2009 Nissan 350Z

2003 350z. I checked threads but still no fix

Old 07-13-2019, 10:00 AM
  #1  
Joeyde
Registered User
Thread Starter
 
Join Date: Jul 2019
Location: Mass
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Default 2003 350z. I checked threads but still no fix

My slip light and vdc lights are on. Car wont go over 2000rpms, i reset ecu, but removing battery and depressing brake, also let it sit over night with battery disconnected, codes still lit, and still wont rev. Parts i threw at it are, maf sensor, throttle body, accelerator position sensor. Still say problen.. I checked the air filter its dry. I may have done more just can't think of what... I had the codes. See if i can find my notes. Any help will be appreciated.
Joeyde is offline  
Old 07-13-2019, 10:11 AM
  #2  
dkmura
General & DIY Moderator
MY350Z.COM
iTrader: (62)
 
dkmura's Avatar
 
Join Date: May 2002
Location: Aurora, Colorado
Posts: 6,867
Received 740 Likes on 507 Posts
Default

Welcome- but posting a question like this is better placed in the "maintenance and repair" section. It also helps to know exactly what codes were being shown, both before and after you threw a bunch of parts at it. The diagnostic system in your Z will only activate limp mode if you have a code that could cause safety issues or serious engine damage, so why did you replace the other parts in the first place?
dkmura is offline  
Old 07-13-2019, 10:23 AM
  #3  
Joeyde
Registered User
Thread Starter
 
Join Date: Jul 2019
Location: Mass
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by dkmura View Post
Welcome- but posting a question like this is better placed in the "maintenance and repair" section. It also helps to know exactly what codes were being shown, both before and after you threw a bunch of parts at it. The diagnostic system in your Z will only activate limp mode if you have a code that could cause safety issues or serious engine damage, so why did you replace the other parts in the first place?
Posted over there
Joeyde is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Cux350z
Feedback & Suggestions for Our Forum
13
02-10-2015 01:25 PM
buzzardmountain
Feedback & Suggestions for Our Forum
4
02-06-2006 12:01 PM
demonx
Wheels & Tires
3
04-29-2005 04:51 AM
M Powered
2003-2009 Nissan 350Z
1
09-10-2002 06:33 PM


Thread Tools
Search this Thread
Quick Reply: 2003 350z. I checked threads but still no fix


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: