Notices
2003-2009 Nissan 350Z

Installed used Gemini exhaust and does not sound like it should

Old 07-11-2019, 09:24 AM
  #1  
Jsmix11
Registered User
Thread Starter
 
Join Date: Jul 2019
Location: Kansas City
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default Installed used Gemini exhaust and does not sound like it should

Hey guys. Fairly new owner here. Stock 05 Roadster. I purchased a used Invidia Gemini and I tried to install it myself but the bolts were all rusted on and I don't have the power tools so had a shop install it. Picked it up and it does not even sound close to what it should sound like. I looked and everything was installed correctly. No leaks. Nothing. So money down the drain there. It's just way too loud and sounds like I have straight pipes.

I'm going to bite the bullet and order me a new Gemini cat back system. I've been looking online and the price is around $900 shipped. Can't seem to find anything lower than that.

I've searched around the forum and can't find anything better. Any suggestions on sites to order from / stay away from?

TIA.
Jsmix11 is offline  
Old 07-11-2019, 09:38 AM
  #2  
travlee
Master
iTrader: (8)
 
travlee's Avatar
 
Join Date: Jul 2011
Location: Texas
Posts: 38,107
Received 6,022 Likes on 4,162 Posts
Default

do you have cats, test pipes or what.... take a pic of the exhaust from the back of the car
travlee is offline  
Old 07-11-2019, 09:40 AM
  #3  
travlee
Master
iTrader: (8)
 
travlee's Avatar
 
Join Date: Jul 2011
Location: Texas
Posts: 38,107
Received 6,022 Likes on 4,162 Posts
Default

here is my old car with kinetix cats and gemini


art pipes and gemini

travlee is offline  
The following users liked this post:
khnitz (07-11-2019)
Old 07-11-2019, 10:06 AM
  #4  
Jsmix11
Registered User
Thread Starter
 
Join Date: Jul 2019
Location: Kansas City
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default





Jsmix11 is offline  
Old 07-11-2019, 10:18 AM
  #5  
travlee
Master
iTrader: (8)
 
travlee's Avatar
 
Join Date: Jul 2011
Location: Texas
Posts: 38,107
Received 6,022 Likes on 4,162 Posts
Default

i know for sure that the right tube should be going over the sway bar
travlee is offline  
Old 07-11-2019, 11:40 AM
  #6  
Freise
Registered User
 
Join Date: Jan 2015
Location: Pennsylvania
Posts: 95
Likes: 0
Received 13 Likes on 13 Posts
Default

Definitely not installed correctly. Maybe even leaking around flanges?
Freise is offline  
Old 07-11-2019, 04:20 PM
  #7  
jellofuel
Registered User
 
Join Date: Jul 2017
Location: Carrollton, GA
Posts: 137
Received 39 Likes on 30 Posts
Default

That passenger side piping is upside down for sure. That won't fix the issue, but you can correct this so it doesn't scrape. The new hardware will make the install easy. It looks like the flex pipe is scraped up, I'd take a closer look there to see if it's leaking.

On a completely unrelated side note, looks like your rear diff bushing is toast.
jellofuel is offline  
Old 07-12-2019, 06:59 AM
  #8  
Bak3rme
Registered User
iTrader: (1)
 
Join Date: Dec 2013
Location: Boston, MA
Posts: 372
Received 45 Likes on 35 Posts
Default

agreed with statements above. the passenger side pipe should be above the sway bar (although this will not change the sound). I have the gemini also and I got it because of the closer to OEM sound. if its too loud you may have a leak somewhere (could be near the flange welds). Also, 3rd picture you posted (the one with cats in it, it looks like your Y pipe has flex portion in it. Mine did not come with the flex portion so it looks like you may of gotten a different Y pipe? You may of gotten a different Y pipe with the rest of the exhaust being gemini. Mine does not have any flex portions in the exhaust. This could also be an older model of the invidia gemini before they upgraded to a NO FLEX sytsem.

hope you get it figured out. its is one of the better sounding less obnoxious exhaust for the VQ35DE IMHO!
Bak3rme is offline  
Old 07-12-2019, 09:25 AM
  #9  
iideadeyeii
Registered User
iTrader: (6)
 
Join Date: Nov 2011
Location: Lawtown
Posts: 2,904
Received 232 Likes on 185 Posts
Default

Post an audio clip?
iideadeyeii is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jmrsyrs
2003-2009 Nissan 350Z
2
09-23-2018 02:23 AM
IsDatIt
SoCal Marketplace
43
05-09-2012 11:17 AM
scrapser
2009+ 370Z
11
10-28-2008 06:40 AM


Thread Tools
Search this Thread
Quick Reply: Installed used Gemini exhaust and does not sound like it should


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: