Notices
2003-2009 Nissan 350Z

Problem with 2003 electrical

Old 03-09-2019, 08:21 PM
  #1  
skankwhisperer
Registered User
Thread Starter
 
Join Date: Jul 2018
Location: AZ
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default Problem with 2003 electrical

HI all.
This morning I changed my oil and put new rotors and brakes on.i had a weird wobble and intermittent scrape so I figured it was a warped rotor.

Well i finish up and take it for a short drive .right front wheel starts scraping and I'm just around the corner from my place so I get it home..
pull into the driveway and its smoking..I let it cool down and pull the wheel and rotor ,well the part on the wheel bearing assembly has broken off where the plate is that has the lug bolts on it..the only thing that was holding the wheel in was the caliper..crazy

So I fix that .and my battery is dead .
I'm looking at the positive cable and where it hooks to the fuseable link its bare and not wound tight anymore.

So.i cut ,strip and clean it and put a new end on it...now it's not charging and the lights in the dash are all going crazy...
And goes into limp mode
Never had problems before besides an alternator a few months ago..

Wtf?

Anyone have an idea what's going on?any help would be appreciated

Last edited by skankwhisperer; 03-09-2019 at 08:27 PM.
skankwhisperer is offline  
Old 03-09-2019, 08:26 PM
  #2  
skankwhisperer
Registered User
Thread Starter
 
Join Date: Jul 2018
Location: AZ
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

Oh.not throwing any codes but the brake and battery light is on
skankwhisperer is offline  
Old 03-12-2019, 05:34 PM
  #3  
icer5160
Registered User
iTrader: (4)
 
Join Date: May 2010
Location: Mountain View, CA
Posts: 560
Received 73 Likes on 59 Posts
Default

Battery might be low or near dead, if it wasn't connected properly it most likely wasn't being charged by the alternator. I suggest getting it load tested along with the alternator, if it fails, simply replace it.
-Icer
icer5160 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dtoma_nyc
Maintenance & Repair
0
01-25-2006 05:00 PM
350zOnJuice
Audio & Video
2
05-29-2005 08:02 PM
kosta157
Maintenance & Repair
2
09-01-2004 11:59 AM
Shocka
Engine & Drivetrain
0
04-01-2004 07:39 PM
ZThang
Exterior & Interior
3
02-03-2004 06:30 PM


Thread Tools
Search this Thread
Quick Reply: Problem with 2003 electrical


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: