my horns dont work! - MY350Z.COM - Nissan 350Z and 370Z Forum Discussion

Notices
370Z Maintenance & Repair 370Z upkeep and diagnosing/fixing problems

my horns dont work!

Old 12-20-2010, 01:07 PM
  #1  
igottaZ
Registered User
Thread Starter
 
Join Date: Feb 2009
Location: texas
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default my horns dont work!

ok so my horns stopped working, i ordered 2 more and plugged them in. still nothing. what are all the possibilities of what the problem could be and how do i check for them? besides the obvious blown fuse... fuse is good
igottaZ is offline  
Old 12-20-2010, 04:14 PM
  #2  
igottaZ
Registered User
Thread Starter
 
Join Date: Feb 2009
Location: texas
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok new problem. turns out its because i need a new place to mount my horns......sucks
igottaZ is offline  
Old 12-20-2010, 04:42 PM
  #3  
R350Zz33
Registered User
iTrader: (4)
 
R350Zz33's Avatar
 
Join Date: Apr 2008
Location: manorville ny
Posts: 1,907
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by igottaZ View Post
ok new problem. turns out its because i need a new place to mount my horns......sucks
new intake?
R350Zz33 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ars88
Zs & Gs For Sale
18
04-04-2016 08:52 AM
Lt_Ballzacki
Brakes & Suspension
13
10-24-2015 09:56 AM
_bit
New Owners
5
10-02-2015 08:49 AM
hulkout
Tuning
1
09-30-2015 01:33 PM


Thread Tools
Search this Thread
Quick Reply: my horns dont work!


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: