Cylinder 2 misfire please HELP - MY350Z.COM - Nissan 350Z and 370Z Forum Discussion

Notices
Engine & Drivetrain VQ Power and Delivery

Cylinder 2 misfire please HELP

Old 02-05-2019, 10:53 PM
  #1  
gearhead350
Registered User
Thread Starter
 
Join Date: Mar 2015
Location: Los Angeles, CA
Posts: 49
Thanks: 0
Thanked 1 Time in 1 Post
Default Cylinder 2 misfire please HELP

Please help. Yesterday i drove my Z in kinda heavy rain and the car started bogging and threw these codes....

P1144 HO2S1 Bank 1
P1164 HO2S1 Bank 2
P0302 Cylinder 2 misfire

I cleared the codes and let the car sit for a few. After sitting i went out and drove it when the roads were dry and it stopped bogging and no o2 sensor codes. However the car still misfires at between idle and 1.5k rpm. Its not a constant misfire it just kinda hiccups every few seconds. I did all the regular misfire checking stuff by switching around the coils and plugs and it stayed at cylinder 2. So i replaced the injector today and still didnt fix it. I also did a compression test on cylinder 2 and it was perfect....The CEL does not come on but i have the scanner plugged in and the misfire code doesnt pop up until 10 minutes of the scanner plugged in and the car idling. Im so lost on this and feel like all this had to do with the water...
Is it possible i shorted something in the wiring harness? If it did short how would that only cause cylinder 2 misfire? Please HELP
gearhead350 is offline  
Old 02-06-2019, 05:40 AM
  #2  
travlee
Master
iTrader: (8)
 
travlee's Avatar
 
Join Date: Jul 2011
Location: Texas
Posts: 37,123
Thanked 5,788 Times in 3,984 Posts
Default

try swapping coil packs with another cylinder... see if it follows it
travlee is online now  
Old 02-06-2019, 10:16 AM
  #3  
gearhead350
Registered User
Thread Starter
 
Join Date: Mar 2015
Location: Los Angeles, CA
Posts: 49
Thanks: 0
Thanked 1 Time in 1 Post
Default

Originally Posted by travlee View Post
try swapping coil packs with another cylinder... see if it follows it
I did all that stuff already
gearhead350 is offline  
Old 02-06-2019, 10:54 AM
  #4  
travlee
Master
iTrader: (8)
 
travlee's Avatar
 
Join Date: Jul 2011
Location: Texas
Posts: 37,123
Thanked 5,788 Times in 3,984 Posts
Default

did you check the plugs.
travlee is online now  
Old 02-06-2019, 10:55 AM
  #5  
travlee
Master
iTrader: (8)
 
travlee's Avatar
 
Join Date: Jul 2011
Location: Texas
Posts: 37,123
Thanked 5,788 Times in 3,984 Posts
Default

how many miles, ever changed the plugs
travlee is online now  
Old 02-06-2019, 10:57 AM
  #6  
gearhead350
Registered User
Thread Starter
 
Join Date: Mar 2015
Location: Los Angeles, CA
Posts: 49
Thanks: 0
Thanked 1 Time in 1 Post
Default

Originally Posted by travlee View Post
how many miles, ever changed the plugs
Motor has 52k miles and plugs are 3 days old...like it said in the post im pretty sure it has to do with the water. I switched plugs around switched coils around, replaced injector, checked compression and nothing changed. So im assuming i shorted something
gearhead350 is offline  
Old 02-06-2019, 11:03 AM
  #7  
travlee
Master
iTrader: (8)
 
travlee's Avatar
 
Join Date: Jul 2011
Location: Texas
Posts: 37,123
Thanked 5,788 Times in 3,984 Posts
Default

or there is still moisture somewhere
travlee is online now  
Old 02-06-2019, 11:05 AM
  #8  
gearhead350
Registered User
Thread Starter
 
Join Date: Mar 2015
Location: Los Angeles, CA
Posts: 49
Thanks: 0
Thanked 1 Time in 1 Post
Default

Originally Posted by travlee View Post
or there is still moisture somewhere
Possibly, im just so lost with this, the misfire didnt start until it threw those o2 codes but the o2 codes are gone
gearhead350 is offline  
Old 02-06-2019, 11:21 AM
  #9  
travlee
Master
iTrader: (8)
 
travlee's Avatar
 
Join Date: Jul 2011
Location: Texas
Posts: 37,123
Thanked 5,788 Times in 3,984 Posts
Default

spray connectors with wd40,,, drive around for a bit
travlee is online now  
Old 02-06-2019, 11:22 AM
  #10  
gearhead350
Registered User
Thread Starter
 
Join Date: Mar 2015
Location: Los Angeles, CA
Posts: 49
Thanks: 0
Thanked 1 Time in 1 Post
Default

Originally Posted by travlee View Post
spray connectors with wd40,,, drive around for a bit
Cylinder 2 coil connector?
gearhead350 is offline  
Old 02-06-2019, 12:23 PM
  #11  
travlee
Master
iTrader: (8)
 
travlee's Avatar
 
Join Date: Jul 2011
Location: Texas
Posts: 37,123
Thanked 5,788 Times in 3,984 Posts
Default

yeah, that will displace the water that is in there
travlee is online now  
Old 02-06-2019, 12:29 PM
  #12  
gearhead350
Registered User
Thread Starter
 
Join Date: Mar 2015
Location: Los Angeles, CA
Posts: 49
Thanks: 0
Thanked 1 Time in 1 Post
Default

Originally Posted by travlee View Post
yeah, that will displace the water that is in there
Ill give that a try, thank you!
gearhead350 is offline  
Old 02-06-2019, 02:19 PM
  #13  
gearhead350
Registered User
Thread Starter
 
Join Date: Mar 2015
Location: Los Angeles, CA
Posts: 49
Thanks: 0
Thanked 1 Time in 1 Post
Default

I just read my long term fuel trims and bank 1 is at 102% bank 2 is at 100% and neither are changing
gearhead350 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Black350z9972
Engine & Drivetrain
2
01-25-2014 08:36 PM
burubuduy
Maintenance & Repair
1
09-27-2010 03:29 PM
RJ's Z
Maintenance & Repair
3
06-28-2010 08:35 AM
350zz053
Engine & Drivetrain
11
09-09-2006 05:10 PM
350Zzzz
Engine & Drivetrain
40
12-16-2003 09:12 PM


Thread Tools
Search this Thread
Quick Reply: Cylinder 2 misfire please HELP


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: