Go Back  MY350Z.COM - Nissan 350Z and 370Z Forum Discussion > 350Z Tech Area > Maintenance & Repair
Reload this Page >

HELP. p2135 code for bad throttle body, replaced it and hell broke loose.

Notices
Maintenance & Repair 350Z up keep and diagnosing/fixing problems

HELP. p2135 code for bad throttle body, replaced it and hell broke loose.

Old 11-09-2014, 06:32 PM
  #1  
Zillest909
Registered User
Thread Starter
 
Join Date: Oct 2014
Location: Rancho Cucamonga
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Default HELP. p2135 code for bad throttle body, replaced it and hell broke loose.

Hey guys, first post here sorry in advance if this is reposted but ive been searching for hours and cant find anyone with this specific issue. So i got the throttle body code, SS, limp mode and all that fun stuff. So i replaced he throttle body today, reset and re-calibrated everything, (installed with negative cable disconnected) and voila! It worked. Car was left for about an hour and i came back to the same BS code and limp mode, however this time limp mode wouldn't stop occurring as it usually did after a couple restarts. I eventually realized that it would happen only after i would reset the ECU on board, and then turn on my headlights!! I'm tripping out, any help is greatly appreciated !
Zillest909 is offline  
Old 11-10-2014, 05:35 AM
  #2  
johndoesdamage
Registered User
iTrader: (9)
 
Join Date: Sep 2008
Location: LAS VEGAS
Posts: 267
Likes: 0
Received 0 Likes on 0 Posts
Default

Could be your pedal position Sensor also
johndoesdamage is offline  
Old 11-10-2014, 09:17 AM
  #3  
Zillest909
Registered User
Thread Starter
 
Join Date: Oct 2014
Location: Rancho Cucamonga
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Default

Yeah I guess that's possible! I want to read the code that it's spitting out now! Because its a very specific issue so I'm very curious as to why the hell it's happening
Zillest909 is offline  
Old 11-10-2014, 10:27 AM
  #4  
B.Sterling
Registered User
 
Join Date: Sep 2012
Location: Winona, ON
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Default

had this same problem last week (started right after I installed ebay led tails...) replaced throttle body, didn't fix it. have you installed aftermarket led tails?
I swapped the tails back to oem and it fixed it for me. theres a thread on this, as the led tails most of the power out of the car. forget who but someone has a thread with a fix. it involves wiring in a resistor parrelel to the tail light wiring harness. hope this helps.
B.Sterling is offline  
Old 11-10-2014, 11:14 AM
  #5  
Zillest909
Registered User
Thread Starter
 
Join Date: Oct 2014
Location: Rancho Cucamonga
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by B.Sterling View Post
had this same problem last week (started right after I installed ebay led tails...) replaced throttle body, didn't fix it. have you installed aftermarket led tails?
I swapped the tails back to oem and it fixed it for me. theres a thread on this, as the led tails most of the power out of the car. forget who but someone has a thread with a fix. it involves wiring in a resistor parrelel to the tail light wiring harness. hope this helps.
Interesting. Well I have aftermarket headlights and tails but they've been installed for years now. It all began after the new TB install. So I'll have to look into it. I'm just giving in and taking it to a local shop. Will update after I find out what it is! Thanks for the input guys.

Last edited by Zillest909; 11-10-2014 at 01:41 PM.
Zillest909 is offline  
Old 11-10-2014, 01:43 PM
  #6  
Zillest909
Registered User
Thread Starter
 
Join Date: Oct 2014
Location: Rancho Cucamonga
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Default

UPDATE***
Took it to the shop. Unfortunately am one of the unlucky ones and when the TB went out so did the ecu. Gonna have to buy a new ecu as well it looks like
Zillest909 is offline  
Old 11-11-2014, 02:14 PM
  #7  
samsniss350z
Registered User
 
samsniss350z's Avatar
 
Join Date: Sep 2012
Location: planet earth
Posts: 1,490
Received 23 Likes on 23 Posts
Default

i wrote an extensive post on this problem and there are a few more things you need to check out. use the search function to find it.
samsniss350z is offline  
Old 11-11-2014, 09:00 PM
  #8  
Zillest909
Registered User
Thread Starter
 
Join Date: Oct 2014
Location: Rancho Cucamonga
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by samsniss350z View Post
i wrote an extensive post on this problem and there are a few more things you need to check out. use the search function to find it.
Tried to search for it can't seem to find anything similar or by you. Have a link you can send me? I'd extremely appreciate it !
Zillest909 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
pslamp32
Maintenance & Repair
17
02-08-2017 09:07 AM
Dust
Engine & Drivetrain
0
09-15-2015 08:28 AM
ThreeFiveZero Z
Competition Items
3
09-12-2015 04:33 PM
h8redlights
2003-2009 Nissan 350Z
4
09-11-2015 07:57 PM
Darkspy
VQ35HR
0
09-07-2015 09:09 PM


Thread Tools
Search this Thread
Quick Reply: HELP. p2135 code for bad throttle body, replaced it and hell broke loose.


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: