Vortech 350z Running Rich - Out of Ideas - MY350Z.COM - Nissan 350Z and 370Z Forum Discussion

Notices
Maintenance & Repair 350Z up keep and diagnosing/fixing problems

Vortech 350z Running Rich - Out of Ideas

Reply

 
 
 
Old 12-28-2017, 03:53 PM
  #1  
CJM
Registered User
Thread Starter
iTrader: (3)
 
Join Date: Sep 2013
Location: Pennsylvania
Posts: 788
Thanked 88 Times in 44 Posts
Default Vortech 350z Running Rich - Out of Ideas

Hi All,

I'm out of ideas for troubleshooting and about to turn over the car to my tuner. Before I do that, I'll ask the forum for additional ideas.

The car is running rich under load above quarter throttle. It idles at a fluctuating 14.0-15.0 AFR. Cruises and drives fine even under heavy load - just goes to full rich 10.0 and holds. No new modifications have occurred since the tune. Issue was not seen during tuning so my assumption is something has failed on the car.

A bit of information:
2004 350z
Vortech V3 - SCi with 3.12 Pulley
Tuned with UpRev 3000 miles ago
UpRev GT MAF
NWP Throttle Body
DW600 injectors
Walboro 255 pump
NGK Iridium LFR6AIX-11 plugs (.034" gap)

What has been tested with no success:
Verified wideband as accurate on local dyno. Still made good power.
No boost/vacuum leaks (-24" vacuum and builds boost properly)
MAF cleaned
MAF swapped with friend's UpRev GT
OEM throttle body installed
Fuel Pressure is 52psi at idle
Spark Plugs replaced (passenger side appeared darker)
Tune reuploaded
Full Tank of 93
No oil consumption
No CELs

Today, I have sent out my injectors to DW for flow testing and cleaning. Thoughts are that the injectors could be dirty and not atomizing fuel properly. Besides that, I have no other ideas and an open to your thoughts. Car does not misfire and drives with no issues, just runs rich under load.






Video of Car Running Rich under load:
https://www.youtube.com/watch?v=A2QK...ature=youtu.be

Last edited by CJM; 12-28-2017 at 03:56 PM.
CJM is offline  
Reply With Quote
Old 12-28-2017, 04:16 PM
  #2  
yosip1115
Know it all
 
Join Date: Jan 2012
Location: CT, RI, MA
Posts: 501
Thanked 28 Times in 26 Posts
Default

Can you post up a data log? At idle and when it happens. Guess you'll have to wait for those injectors

Rpm, load, throttle position sensor, throttle pedal position, short and long term fuel trims, injector duty cycle, coolant temp, afr's, iat, intake cam sol %'s, target afr, ign timing

Last edited by yosip1115; 12-28-2017 at 04:18 PM.
yosip1115 is offline  
Reply With Quote
Old 12-28-2017, 04:25 PM
  #3  
2bad240
Registered User
iTrader: (6)
 
Join Date: Jan 2011
Location: new bern nc
Posts: 1,063
Thanks: 0
Thanked 36 Times in 24 Posts
Default

Definitely something wrong here Is it making boost? Does it break up or just rich? Who did the tune?
2bad240 is offline  
Reply With Quote
Old 12-28-2017, 04:43 PM
  #4  
CJM
Registered User
Thread Starter
iTrader: (3)
 
Join Date: Sep 2013
Location: Pennsylvania
Posts: 788
Thanked 88 Times in 44 Posts
Default

Will take a datalog once I get the injectors back.

Making boost just fine. Made it's normal 5psi at 4-5000rpm but I didn't take it higher. Also making good power which reinforces it making boost. If I overlay my original dyno graph and the troubleshoot graph (different locations - both dynojets), the numbers are similar.

Not breaking up at all. Only symptom is running rich. If I didn't have a wideband and didn't notice the black exhaust/tips, I never would have noticed. Car was tuned by Vince at RT Tuning and made 409whp. Ray, its the same guy who tuned Craig's previous setups. I'm confident the tune was proper as he's quite good and the car made proper power.

Last edited by CJM; 12-28-2017 at 08:33 PM.
CJM is offline  
Reply With Quote
Old 12-30-2017, 05:27 PM
  #5  
rottingcat
Registered User
iTrader: (3)
 
Join Date: Dec 2015
Location: California
Posts: 125
Thanked 13 Times in 12 Posts
Default

in for answer want to learn since i’m putting on my vortech soon
rottingcat is offline  
Reply With Quote
Old 01-05-2018, 07:17 PM
  #6  
CJM
Registered User
Thread Starter
iTrader: (3)
 
Join Date: Sep 2013
Location: Pennsylvania
Posts: 788
Thanked 88 Times in 44 Posts
Default

Update: Injectors "balanced in spec 'like new'". So I'm rather lost. I'll data log upon their arrival through snail mail.

Air: No boost/vac leaks.
Fuel: Pressure is good to the rail. Injectors are good. Fuel rail?
Spark: Plugs replaced. Odds of all coilpacks going bad at same time without misfire is low.
Tune: Reuploaded.
Misc: No oil consumption. Proper power to 5000rpm.

Open to ideas at this point
CJM is offline  
Reply With Quote
Old 01-13-2018, 07:10 AM
  #7  
CJM
Registered User
Thread Starter
iTrader: (3)
 
Join Date: Sep 2013
Location: Pennsylvania
Posts: 788
Thanked 88 Times in 44 Posts
Default

Got the car back together last night - still the same issues. Was able to get some datalogs for anyone that wants to take a look.

Attached Datalogs:
Idle
Acceleration (Normal acceleration, goes rich at partial throttle around 3000rpm)
WOTs (3 brief WOT accelerations: easing into WOT, starting below 3000rpm and starting above 3000rpm)

Any ideas are appreciated as I set an appointment up with my local shop.
CJM is offline  
Reply With Quote
Old 01-13-2018, 07:37 AM
  #8  
yosip1115
Know it all
 
Join Date: Jan 2012
Location: CT, RI, MA
Posts: 501
Thanked 28 Times in 26 Posts
Default

How are your short term fuel trims at idle?
yosip1115 is offline  
Reply With Quote
Old 01-13-2018, 08:25 AM
  #9  
CJM
Registered User
Thread Starter
iTrader: (3)
 
Join Date: Sep 2013
Location: Pennsylvania
Posts: 788
Thanked 88 Times in 44 Posts
Default

Originally Posted by yosip1115 View Post
How are your short term fuel trims at idle?
I attempted to log those as well and couldn't get a value. Let me dive into it a bit when I get home
CJM is offline  
Reply With Quote
Old 01-13-2018, 08:39 AM
  #10  
yosip1115
Know it all
 
Join Date: Jan 2012
Location: CT, RI, MA
Posts: 501
Thanked 28 Times in 26 Posts
Default

Originally Posted by CJM View Post
I attempted to log those as well and couldn't get a value. Let me dive into it a bit when I get home
Sounds good. should be within 3% of 100 at all times
yosip1115 is offline  
Reply With Quote
Old 01-15-2018, 08:54 AM
  #11  
350z006
Registered User
iTrader: (79)
 
350z006's Avatar
 
Join Date: Jan 2007
Location: Long Beach, CA
Posts: 1,445
Thanked 7 Times in 7 Posts
Default

I don't know if this helps at all, but before I went standalone my Uprev Vortech tune would tend to shift and start running rich....almost to the point of needing a re-tune once a year...not sure what to attribute it to...
350z006 is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
fairladyz13
Tuning
12
10-19-2012 10:01 AM
3z5x06rz
Engine & Drivetrain
1
09-02-2012 05:18 PM
617G
Forced Induction
34
10-14-2006 06:16 AM
kcobean
Forced Induction
11
07-22-2005 07:43 PM

Forum Jump

Thread Tools
Search this Thread
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: