P0303 after nitrous pass - MY350Z.COM - Nissan 350Z and 370Z Forum Discussion



Nitrous Oxide Too soon, jr.

Reply
 
 
 
Thread Tools Search this Thread
Old 10-09-2017, 07:05 AM   #1
Zeus04
Registered User
Thread Starter
 
Join Date: Oct 2017
Location: Sumiton, AL
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default P0303 after nitrous pass

My 04 has been running fine and performs great until 2nd nitrous pass. Currently using the zex kit on 100 shot with a retard timing of -2 degrees. I have a misfire on cylinder 3, and thought I burnt up the spark plugs so I bought the ngk 1 degree colder plugs and same issue... No oil in cylinder 3 and if you unplug the coil pack you can definitely hear the miss... It's got power loss and hesitates at wot no matter what rpm you start out. Things I have done: cleaned maf, changed plugs all 6, checked for leaks around intake, and made sure tps was reading properly. Any help would be greatly appreciated.. I don't want to hear the compression is bad as that would be the worst case scenario. Current mods are intake, full exhaust, nitrous.
Zeus04 is offline   Reply With Quote
Old 10-10-2017, 02:27 AM   #2
Conway_160
Registered User
iTrader: (1)
 
Join Date: Dec 2012
Location: Middle of the USA
Posts: 1,601
Thanked 70 Times in 63 Posts
Default

Do a compression check, make sure you didn't fry your rings.
Conway_160 is offline   Reply With Quote
The Following User Says Thank You to Conway_160 For This Useful Post:
BluestreamDE (10-10-2017)
Old 10-10-2017, 02:34 AM   #3
BluestreamDE
Registered User
 
BluestreamDE's Avatar
 
Join Date: Mar 2016
Location: Texas
Posts: 493
Thanked 67 Times in 55 Posts
Default

Quote:
Originally Posted by Zeus04 View Post
using the zex kit on 100 shot with a retard timing of -2 degrees.


I'm no nitrous guru, but I have read that you need to richen your WOT AFR tables at least .5 or you will run lean once nitrous is engaged and spraying. I see you reduced timing but did you fix the fuel portion of the tune?
BluestreamDE is offline   Reply With Quote
Old 10-10-2017, 03:07 AM   #4
tcode
Registered User
iTrader: (7)
 
tcode's Avatar
 
Join Date: Jul 2012
Location: EU/Croatia
Posts: 350
Thanked 7 Times in 4 Posts
Default

Burnt exhaust valve is one possibility too.
tcode is offline   Reply With Quote
Old 10-10-2017, 08:27 AM   #5
BakaN20
Registered User
iTrader: (26)
 
Join Date: Jun 2006
Location: Hamden, CT
Posts: 1,284
Thanks: 0
Thanked 19 Times in 17 Posts
Default

Were you running 1 step colder plugs before this happened or stock plugs? Do you have an afr gauge? What was the afrs when you were spraying. What is your activation window?
BakaN20 is offline   Reply With Quote
Old 10-10-2017, 08:51 AM   #6
CK_32
Registered User
iTrader: (1)
 
CK_32's Avatar
 
Join Date: Jan 2016
Location: California
Posts: 3,010
Thanked 289 Times in 245 Posts
Default

I'm going to assume this was a dry shot? Not a wet?
CK_32 is offline   Reply With Quote
Old 10-11-2017, 12:07 PM   #7
iideadeyeii
Registered User
iTrader: (6)
 
Join Date: Nov 2011
Location: Lawtown
Posts: 2,272
Thanked 112 Times in 86 Posts
Default

Quote:
Originally Posted by Conway_160 View Post
Do a compression check, make sure you didn't fry your rings.
Why haven't you checked compression. Right after inspecting the plug this is the second thing you should have done!!!
iideadeyeii is offline   Reply With Quote
Old 10-11-2017, 04:43 PM   #8
Conway_160
Registered User
iTrader: (1)
 
Join Date: Dec 2012
Location: Middle of the USA
Posts: 1,601
Thanked 70 Times in 63 Posts
Default

Quote:
Originally Posted by iideadeyeii View Post
Why haven't you checked compression. Right after inspecting the plug this is the second thing you should have done!!!
Maybe he did check it after I sugested it and found he wrecked his motor, now he's in a corner crying.
Conway_160 is offline   Reply With Quote
The Following 2 Users Say Thank You to Conway_160 For This Useful Post:
BluestreamDE (10-11-2017), iideadeyeii (10-12-2017)
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -8. The time now is 07:10 PM.


Copyright 2002 - 2017, MY350Z.COM All Rights Reserved.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: