Notices
2003-2009 Nissan 350Z

p1084 revup B2 Exh cam sensor. access?

Old 06-06-2019, 06:23 AM
  #1  
masterjr33
Registered User
Thread Starter
 
masterjr33's Avatar
 
Join Date: May 2019
Location: FL
Posts: 22
Likes: 0
Received 4 Likes on 4 Posts
Default p1084 revup B2 Exh cam sensor. access?

The car has pulled a P1084 on me.
I ordered a new nissan sensor due to the horror stories about aftermarket ones.
I also ordered a crank sensor incase. because the flow chart has that as the last step.

taking a quick search on here i get alot of old info and some that may not apply to the revup engine and its different sensors.

From what i can tell my issue is the bank 2 ( drivers side) exhaust sensor. which is the furthest out on the head.
bolted to the block with a 10mmT/B . and has a pushlock style connector.
Also it should be the "straight" style sensor.

I have cleared the codes. checked the oil . and code came right back.
I would like to proceed with a sensor replacement.
Looking around under the hood it looks like a bugger to get to this outboard revup sensor.


Anyone have any advice or has done this before? Easier to get from underneath? or go in from the top.
do i need to remove the TB or the plenum to access?
masterjr33 is offline  
Old 06-06-2019, 10:15 AM
  #2  
rustyschopshop
Registered User
 
rustyschopshop's Avatar
 
Join Date: Mar 2014
Location: Watauga, Texas
Posts: 750
Received 80 Likes on 66 Posts
Default

would recommend removing the intake manifold for the drivers side, it is a little more work but will help you ensure you don't break the pigtail removing it. The pushlock is cumbersome to get to. Take your time and should go smoothly.
rustyschopshop is offline  
Old 06-08-2019, 04:11 PM
  #3  
masterjr33
Registered User
Thread Starter
 
masterjr33's Avatar
 
Join Date: May 2019
Location: FL
Posts: 22
Likes: 0
Received 4 Likes on 4 Posts
Default

good news.
got under the hood today and you can lay a blanket on the passenger side of the car.
lean in from the passenger side and go straight back to the sensor.

I had ZERO luck unplugging the sensor while installed.
So i unbolted the sensor. and removed it. and pulled it my way some.
This allowed both hands on the sensor and connector and it popped off cleanly.

I was able to get a standard 3/8 ratchet back there with a deepwell 10mm right on the bolt and still had good access to work the ratchet.

the Oring on my old sensor was flat and dry. I am sure it would have leaked very soon.

I bolted in the new sensor and reset the ECU with the pedal.
A quick joy ride with the car finally out of limp mode ensued.
No check engine light returned.

A block from the house i checked oil pressure gauge at a stop light and noticed it was stuck at 60+ at idle. and instanly went over 120 with any RPM searching here shows its 99% chance of being my oil sending unit.

I plan to hit the local yard and grab a used OEM one from some other nissan 3.5 as they all seem to be the same.
I search the aftermarket and they are all from china and have BAD reviews.
the OEM sensor is about 70$.. .
It's always something, but at least my P1084 is RESOLVED.
masterjr33 is offline  
The following users liked this post:
khnitz (06-11-2019)
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Chris Bobinger
Engine & Drivetrain
2
12-11-2016 09:37 AM
mkiv20vt
Maintenance & Repair
4
07-01-2016 10:06 AM
joeyz12
Maintenance & Repair
42
07-01-2016 04:23 AM
Dynosty
Product Announcements
6
09-02-2011 02:59 AM


Thread Tools
Search this Thread
Quick Reply: p1084 revup B2 Exh cam sensor. access?


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: