Notices
Maintenance & Repair 350Z up keep and diagnosing/fixing problems

P1084 06 350z

Old 08-22-2013, 07:15 PM
  #1  
mkiv20vt
Registered User
Thread Starter
 
mkiv20vt's Avatar
 
Join Date: Jan 2011
Location: Northern FL
Posts: 190
Likes: 0
Received 4 Likes on 3 Posts
Default P1084 06 350z

Hey guys,

Last week, car started to run a little weird (1100rpm idle, CEL) so i pulled the codes via my accessport and found p1084 Ext Tim Sensor B2. Looked it up online and found out this has been cause by either low oil, oil on the sensor, or a bad sensor.

Checked off the first two(oil level is normal), and proceeded to buy a new cam position sensor from the dealer for b2(drivers side). Swapped the sensors out, and reset the ECU. Car started fine and ran fine for about 10 miles when the code came back and the 1100rpm idle began again. Car smells rich at idle (confirmed via AP, 12.6-12.7AFR at idle after the engine is warmed up).

Any suggestions as to what else it could be to throw this code?

Thanks!
mkiv20vt is offline  
Old 08-27-2013, 04:15 PM
  #2  
mkiv20vt
Registered User
Thread Starter
 
mkiv20vt's Avatar
 
Join Date: Jan 2011
Location: Northern FL
Posts: 190
Likes: 0
Received 4 Likes on 3 Posts
Default

Problem solved.

For those who are having an issue with this, check both the Cam Position Sensor the "Exhaust Valve Timing Control Position Sensor" (the bolded sensor number actually caused my issue), #28(Bank1) and #29(Bank2) from the attached photo.

Name:  fsmcams_zps09d92d5c.jpg
Views: 797
Size:  75.8 KB

Make sure when purchasing this sensor from the dealer, you specify that you have a REVUP DE, as the 06 Z may come up as a DE in the Parts Dept computer.

I also utilized this (http://g35driver.com/forums/g35-coup...y-version.html) to help diagnose the sensors and reset the ECU, but this thread is focused on non revup DEs without variable cam timing for both intake and exhaust cams, therefore only having the two Cam Position Sensors (#13 and #24)

Hopefully this helps anyone in the future fix their issue!

Last edited by mkiv20vt; 08-27-2013 at 04:16 PM. Reason: speeeling
mkiv20vt is offline  
Old 04-20-2016, 10:08 AM
  #3  
gotama
Registered User
 
Join Date: Nov 2015
Location: /
Posts: 48
Received 0 Likes on 0 Posts
Default

my 06 rev up de giving me the exact same error P1084 - exhaust valve timing control position sensor (Bank 2). I need to replace the sensor


Does anyone have the part number for this ? I cant find it anywhere.


Appreciate any help.


Cheers
gotama is offline  
Old 04-22-2016, 09:32 PM
  #4  
gotama
Registered User
 
Join Date: Nov 2015
Location: /
Posts: 48
Received 0 Likes on 0 Posts
Default

Anyone ever had this issue P1084 with his 06' rev up, however not with the cam position sensor located at the back, but the exhaust sensor located at the front part of the engine ?


I'm having a hard time trying to find the info. of this sensor. Doing lots of research but this damn sensor is not popping up anywhere. Not even the Nissan dealer could find the info..
gotama is offline  
Old 07-01-2016, 10:06 AM
  #5  
Battmannes16
Registered User
 
Join Date: Jul 2016
Location: St. Louis Missouri
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
Default

Battmannes16 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Dsowe
Exterior & Interior
11
01-09-2019 04:20 PM
liqalu04
Engine & Drivetrain
22
10-25-2017 05:34 AM
issyz
2003-2009 Nissan 350Z
6
07-02-2017 03:04 PM
nanotech
Exhaust
6
10-02-2015 05:02 AM
samansharif
Brakes & Suspension
1
09-25-2015 12:31 PM


Thread Tools
Search this Thread
Quick Reply: P1084 06 350z


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: