HELP- Car wont engage in clutch after clutch replacement - MY350Z.COM - Nissan 350Z and 370Z Forum Discussion

Go Back  MY350Z.COM - Nissan 350Z and 370Z Forum Discussion > 350Z Tech Area > Maintenance & Repair
Reload this Page >

HELP- Car wont engage in clutch after clutch replacement

Notices
Maintenance & Repair 350Z up keep and diagnosing/fixing problems

HELP- Car wont engage in clutch after clutch replacement

Old 10-22-2018, 07:17 PM
  #1  
Heizuke
Registered User
Thread Starter
 
Join Date: Oct 2018
Location: Minnesota
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default HELP- Car wont engage in clutch after clutch replacement

Hi there I'm new on the forum also a beginner when working on cars and I would like some of you guys help. So basically about a month ago I installed an exedy clutch to my 2008 350z because I was changing the slave so I thought might as well change the clutch as well. After the install I realized that it was hard to put it into gear and the higher I went the harder it becomes. I thought that it might've been because the master wasn't pushing enough fluid to the slave so I replaced the master but I still had the same result. So I opened the transmission again this time I installed the Cmak CSC elimination kit and put it back together. Now after I was done I dealt with the same issue when it's hard to put it into gear and the higher the gears go the harder it is to put it into gear(It's impossible to put it in reverse). So I thought since this is the second time happening I decided to just drop it and test drive it maybe it will fix itself when the disc gets worn but no. Now when it's on the ground it doesnt engage in any gear at all. At the moment I'm out of options on what to do, I really dont want to drop it a second time because it's a pain to do so but if I must I'll do it. I just want to know what I did wrong and how do I solve it. I read somewhere that the pilot bearing has to be replaced when doing a clutch but I didn't do it could that cause that issue? Or what other thing could be affecting it. Any ideas would be appreciated it. Thanks
Heizuke is offline  
Old 10-23-2018, 06:59 AM
  #2  
iideadeyeii
Registered User
iTrader: (6)
 
Join Date: Nov 2011
Location: Lawtown
Posts: 2,813
Thanked 213 Times in 171 Posts
Default

Defective pressure plate? Happened to me once and it wouldn't let me fully disengage the clutch.
iideadeyeii is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
SoCali-Z
Maintenance & Repair
6
02-06-2016 05:39 PM
Kwarwick09
Engine & Drivetrain
1
06-12-2014 02:58 PM
vito350zed
Maintenance & Repair
0
05-10-2013 10:53 AM
Zee-u-later
Maintenance & Repair
28
03-08-2013 08:42 PM
k1653d
Engine & Drivetrain
8
11-28-2011 04:15 PM


Thread Tools
Search this Thread
Quick Reply: HELP- Car wont engage in clutch after clutch replacement


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: