Notices
Maintenance & Repair 350Z up keep and diagnosing/fixing problems

Airbag light flashing... needs to be fixed... Dealer rant...

Old 08-09-2012, 09:10 PM
  #21  
SoldzMyZ
Registered User
Thread Starter
iTrader: (11)
 
SoldzMyZ's Avatar
 
Join Date: Nov 2007
Location: socal
Posts: 920
Likes: 0
Received 0 Likes on 0 Posts
Default

Neimad, dude thank you so much! This is a good lead. I work on this Sunday : )

If I can fix this issue for good I owe you big time!
SoldzMyZ is offline  
Old 08-09-2012, 09:35 PM
  #22  
Z_enthusiast
Registered User
iTrader: (16)
 
Join Date: May 2010
Location: baton rouge
Posts: 1,611
Likes: 0
Received 1 Like on 1 Post
Default

Was the car in ANY accident to make this light come on? if so theres MULTIPLE parts that must be replaced to remove the light.
Z_enthusiast is offline  
Old 08-31-2013, 12:51 PM
  #23  
moloch
Registered User
 
Join Date: Aug 2013
Location: canada
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by Neimad View Post
If the light is flashing there is a code.

1. Turn ignition switch from OFF to ON.
2. Within 1 second after air bag warning lamp is on for 7 seconds and turns off, turn off ignition switch.
3. After ignition switch is off, wait for more than three seconds.
4. Repeat steps 1-3 twice. (Perform 3 times total)
5. Turn ignition switch to ON again.

That puts it in diagnosis mode, after you retrieve the codes do the whole thing over again to go back to user mode. Or disconnect the battery, seems faster.

Count the flashes, report back. If the code pops up when someone sits in the passenger seat its most likely the pass seat weight sensor.
Hi there,

I have the same issue, my error code is 16, 1 slow then 6 fast, however I can't find out what this error means. Any help would be appreciated. Thank you
moloch is offline  
Old 08-31-2013, 01:01 PM
  #24  
Neimad
Registered User
 
Join Date: Dec 2003
Location: Oakland
Posts: 573
Likes: 0
Received 2 Likes on 2 Posts
Default

What year do you have? For an 06 that looks like crash zone sensor, check wiring, check sensor, then module.
Neimad is offline  
Old 01-06-2017, 09:55 AM
  #25  
dboyzalter
6 inch cawk is my fave!
iTrader: (3)
 
Join Date: Apr 2015
Location: Mass
Posts: 6,417
Received 889 Likes on 709 Posts
Default

I need to try this next time I start my car, my lights blinking
dboyzalter is offline  
Old 01-14-2017, 10:14 AM
  #26  
dboyzalter
6 inch cawk is my fave!
iTrader: (3)
 
Join Date: Apr 2015
Location: Mass
Posts: 6,417
Received 889 Likes on 709 Posts
Default

Soooo im trying to get it into diagnostic mode without flooding my car.. Any ideas... I tried a few times with no luck.
dboyzalter is offline  
Old 01-19-2017, 03:16 PM
  #27  
zakmartin
Registered User
 
Join Date: Feb 2009
Location: Seattle, WA
Posts: 2,820
Received 503 Likes on 372 Posts
Default

Originally Posted by dboyzalter View Post
Soooo im trying to get it into diagnostic mode without flooding my car.. Any ideas... I tried a few times with no luck.
Probably too late to write a response on this, but....

I'm not 100% sure this works on the Z, but I've used the method on other cars.

Try starting the car while flooring the gas pedal at the same time. This should clear flood mode by shutting off the fuel pump. Because new fuel isn't being pumped into the engine, the car won't start (obviously,) but it will clear out the existing fuel in the system. Wait a few minutes for any remaining gasoline to clear and then try starting the car again normally.
zakmartin is offline  
Old 03-29-2019, 05:48 PM
  #28  
Dec Radius
Registered User
 
Join Date: Dec 2018
Location: Virginia
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default

There are several threads on this issue here, and hopefully I have hit on the most relevant one. This issue seems to be pretty prevalent on Gs and Zs, and without any genuine accountability being taken on the part of Nissan or Infinity. Just dealers throwing the customer's money at a giant sinkhole. That doesn't work for me.

I have the same issue. When I bought the car (2005 G35 Rev-Up) in December of last year, it had a flashing SRS light. I did a quick search before I pulled off the dealer's lot, put it in diagnostic mode, and then I used the 7on/4off/7on/4off/7on/4off/3on/2off/start for 3/kill for 3/start, and it stayed gone for several months...until 2 weeks ago.

Now I can clear the issue, but with varying results, and it's typically back on within a day or two, and sometimes within 20 minutes. I get the flash code in 2s, (two long, and two short) and with my good OBD II reader, it shows an error code of:

B1134 (1/3) Current
Side Module LH Open

Is the side module located under the Driver's seat?

If anyone has any sage words before I tear into everything, or saw a thread I missed, I'd be thankful for a quick steer in the right direction.
I can read a schematic, and intend to use the helpful information above to troubleshoot the issue.
The car has not been involved in any accidents of note, and it appears to retain all of its original paint, with perhaps a very good re-spray of the front bumper.
Thanks, in advance.


Last edited by Dec Radius; 03-30-2019 at 04:42 AM.
Dec Radius is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ablaine
2003-2009 Nissan 350Z
51
11-29-2016 10:13 AM
Uriyo_
Exterior & Interior
21
11-06-2015 05:59 AM
350z82
Exterior & Interior
19
10-01-2015 06:25 PM
loudtoyz
Engine & Drivetrain
6
09-30-2015 03:48 PM
samansharif
Brakes & Suspension
1
09-25-2015 12:31 PM


Thread Tools
Search this Thread
Quick Reply: Airbag light flashing... needs to be fixed... Dealer rant...


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: