Go Back   MY350Z.COM Forums > 350Z Tech Area > Engine & Drivetrain > Intake Exhaust
Sign in using an external account
Register Forgot Password?
Search


Welcome to my350z.com!
Welcome to my350z.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 10-26-2007, 04:47 PM   #1
gtstang03
Registered User
 
Trader Score: (1)
Join Date: Jul 2006
Location: redding,ca
Posts: 9
Default kinetex V+ install and whistle

Hello guys
i am know i pretty new here, but have done lots of searching and few mods to the z. I recently installed the kinetix v+ plenum. I love the power it made. It seems to idle fine, sometimes pops or rough, but it sorta did this prior. But at part acceleration i get a whistle.
Do i have a intake leak. I am throwing a code too that i can't get to go away, this could be from my Test Pipes, although i have non fowlers in.
People think i have a damn turbo cause the sound. LOL
I want to race it tommarrow night so should i spend the time ripping the intake off and reinstalling.
I added Thin amount of RTV last time, should i do this again.
Any info is great.
Thanks
David
__________________
05 Base 350z - AEM CAI & Megan test Pipes AND 03 mustang gt- Heavily Modded- Built motor,Cammed, Heads,with Paxton NOVI 2000 S/C
gtstang03 is offline   Reply With Quote
Old 10-26-2007, 05:58 PM   #2
ofl0926
Registered User
 
Trader Score: (7)
Join Date: Jun 2006
Location: miami
Posts: 569
Points: 3,106, Level: 34
Points: 3,106, Level: 34 Points: 3,106, Level: 34 Points: 3,106, Level: 34
Today's Activity: 0%
Today's Activity: 0% Today's Activity: 0% Today's Activity: 0%
Send a message via AIM to ofl0926
Default

check to make sure everything sealed right.
__________________
2004 PPW Z- <> Jim Wolf<> AAM<> La Bree<> Apexi<> Tanabe<> Axis<> Yokohama<> SPC <> EBC <> Hawks <> Varis<> Sparco<> Kenwood<> Candence<> Elemental Design<> KnuKoncepts<>Amsoil<>Seibon<>
ofl0926 is offline   Reply With Quote
Old 10-26-2007, 06:02 PM   #3
srt4-no more
Registered User
 
srt4-no more's Avatar
 
Trader Score: (2)
Join Date: Nov 2006
Location: PHX
Posts: 279
Send a message via AIM to srt4-no more
Default

have a leak sumwherr... take it up the top of 2nd and the press the clutch in. if it dies on u its a pretty bad leak. jus run u hands all the way around the plenum and u should be able to feel the air... jus happened to me the other day when i installed my ssv.
srt4-no more is offline   Reply With Quote
Old 10-26-2007, 08:48 PM   #4
terrasmak
Moderator
General, Tech, Motorsports, & Market

 
terrasmak's Avatar
 
Trader Score: (7)
Join Date: Jan 2007
Location: South Korea
Posts: 19,468
Len Novak
Points: 7,100, Level: 55
Points: 7,100, Level: 55 Points: 7,100, Level: 55 Points: 7,100, Level: 55
Today's Activity: 40.5%
Today's Activity: 40.5% Today's Activity: 40.5% Today's Activity: 40.5%
Default

Spray starting fluid around the edges while its running and see if you hear a difference. Next , why did you RTV it ?? Last mine has a slight whistle to it too , its probably normal.
__________________
More screwed up than a football bat hitting a soccer puck into a baseball net.

Last edited by terrasmak; 10-28-2007 at 01:46 AM.
terrasmak is offline   Reply With Quote
Old 10-27-2007, 09:19 AM   #5
gtstang03
Registered User
 
Trader Score: (1)
Join Date: Jul 2006
Location: redding,ca
Posts: 9
Default

Quote:
Originally Posted by terrasmak
Spay starting fluid around the edges while its running and see if you hear a difference. Next , why did you RTV it ?? Last mine has a slight whistle to it too , its probably normal.
Hey guys, thanks for all the response to a newbie on the forum.

I went and bought some starting fluid and sprayed it around the edges and nothing, no engine sound change. I even held the rpms at 2500 too to see if it owuld do it.
I do have a whistle when shuting down from a tube coming out of the passenger side of the plenum. But seems normal. It just pops at idle a little bit, which i heard is normal.

I used rtv as i read it on a write up somewhere. it was a very thin bead.

The whistle is pretty loud but it is only at part throttle and between 1800-3000 rpm, full throttle does not do it.
__________________
05 Base 350z - AEM CAI & Megan test Pipes AND 03 mustang gt- Heavily Modded- Built motor,Cammed, Heads,with Paxton NOVI 2000 S/C
gtstang03 is offline   Reply With Quote
Old 10-27-2007, 10:38 AM   #6
Hydrazine
MOTORDYNE-MY350Z SPONSOR
 
Hydrazine's Avatar
 
Trader Score: (53)
Join Date: Jul 2004
Location: L.A. California
Posts: 4,399
Points: 8,255, Level: 61
Points: 8,255, Level: 61 Points: 8,255, Level: 61 Points: 8,255, Level: 61
Today's Activity: 6.4%
Today's Activity: 6.4% Today's Activity: 6.4% Today's Activity: 6.4%
Default

Quote:
Originally Posted by gtstang03
The whistle is pretty loud but it is only at part throttle and between 1800-3000 rpm, full throttle does not do it.
That's normal.

Even the spacers make that whistle sound.
__________________
Motordyne Engineering - Winner of the Nissan Sport Magazine Plenum Mod Shootout!
http://motordyneengineering.com
Free shipping in the lower 48 states for all order placed on the 1st of the month!
Hydrazine is offline   Reply With Quote
Old 10-27-2007, 05:29 PM   #7
black06z
Registered User
 
black06z's Avatar
 
Trader Score: (1)
Join Date: May 2006
Location: West Coast/Pacific Rim
Posts: 7,234
Points: 4,051, Level: 40
Points: 4,051, Level: 40 Points: 4,051, Level: 40 Points: 4,051, Level: 40
Today's Activity: 0%
Today's Activity: 0% Today's Activity: 0% Today's Activity: 0%
Default

Heard a lot of good things about this V+. Made a big difference with a reflash.
__________________
Air Jordan collection
black06z is offline   Reply With Quote
Old 10-27-2007, 05:54 PM   #8
jcpeyton
Registered User
 
Trader Score: (1)
Join Date: Dec 2004
Location: tucson.az
Posts: 638
Default

I've had the V+ for 8K miles so far. 0 problems. There is a specific tightening pattern and torque specs for the plenum that need to be followed closely.
Also. periodic checking of torque specs in the designated order and adjusting accordingly may be a simple answer.
Kinetix was VERY helpful when I had questions during the installation process. Maybe call them??

Last edited by jcpeyton; 10-27-2007 at 05:59 PM. Reason: Additional information
jcpeyton is offline   Reply With Quote
Old 12-14-2010, 08:32 AM   #9
slmdchvy05
Registered User
 
slmdchvy05's Avatar
 
Trader Score: (3)
Join Date: Oct 2010
Location: DFW Texas
Posts: 249
Points: 1,418, Level: 21
Points: 1,418, Level: 21 Points: 1,418, Level: 21 Points: 1,418, Level: 21
Today's Activity: 0%
Today's Activity: 0% Today's Activity: 0% Today's Activity: 0%
Default

I didnt know there was any specific pattern to tighten the manifold down, but I do now... I have had mine for over a month and just used a t-handle allen wrench on mine to tighten it and have had no problems at all with it, I prob should get a tune but all I have done is the maifold and K&N intake other than that stock...
Click the image to open in full size.
__________________
Black 04 350Z 6MT, pioneer avic-d3, Kinetix Racing SSV intake manifold, K&N Intake, 2" Antenna, Black 19" 370 Rays w/20mm spacers,front 245/35/19 rear 285/35/19 BFG G-Force, 06 Bi-Xenon Headlights, smoked markers, smoked LED tail lights, black door handles.
slmdchvy05 is offline   Reply With Quote
Old 12-14-2010, 01:05 PM   #10
terrasmak
Moderator
General, Tech, Motorsports, & Market

 
terrasmak's Avatar
 
Trader Score: (7)
Join Date: Jan 2007
Location: South Korea
Posts: 19,468
Len Novak
Points: 7,100, Level: 55
Points: 7,100, Level: 55 Points: 7,100, Level: 55 Points: 7,100, Level: 55
Today's Activity: 40.5%
Today's Activity: 40.5% Today's Activity: 40.5% Today's Activity: 40.5%
Default

Quote:
Originally Posted by slmdchvy05 View Post
I didnt know there was any specific pattern to tighten the manifold down, but I do now...
Even with the pics and all you still can't figure out you do not own a V+ plenum.
__________________
More screwed up than a football bat hitting a soccer puck into a baseball net.
terrasmak is offline   Reply With Quote
Old 12-14-2010, 01:43 PM   #11
slmdchvy05
Registered User
 
slmdchvy05's Avatar
 
Trader Score: (3)
Join Date: Oct 2010
Location: DFW Texas
Posts: 249
Points: 1,418, Level: 21
Points: 1,418, Level: 21 Points: 1,418, Level: 21 Points: 1,418, Level: 21
Today's Activity: 0%
Today's Activity: 0% Today's Activity: 0% Today's Activity: 0%
Default

I misread the title and pics don't always pop on my comp at work so there for I did not have any pics to look at at the time. I understand the difference between them now. My bad next time I'll try to use a comp that will show pics on every thread.
__________________
Black 04 350Z 6MT, pioneer avic-d3, Kinetix Racing SSV intake manifold, K&N Intake, 2" Antenna, Black 19" 370 Rays w/20mm spacers,front 245/35/19 rear 285/35/19 BFG G-Force, 06 Bi-Xenon Headlights, smoked markers, smoked LED tail lights, black door handles.
slmdchvy05 is offline   Reply With Quote
Old 12-14-2010, 01:43 PM
MyG37
Infiniti G37




Paid Advertisement
 
 
 
Reply

Tags
04, 2004, 350z, g35, install, intake, kinetix, kn, manifold, pipe, specs, test, torque, v, whistling



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off
Forum Jump

ADVERTISING
INSURANCE CENTER

All times are GMT -8. The time now is 06:20 PM.


Advertise on MY350Z.COM - Terms of Service - Privacy Statement - Jobs
Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2002 - 2008, MY350Z.COM All Rights Reserved.

Admin control Panel Backup