350z Misfire! Nothings working. - MY350Z.COM - Nissan 350Z and 370Z Forum Discussion



Engine & Drivetrain
VQ Power and Delivery



Reply
 
 
 
Thread Tools Search this Thread
Old 01-11-2018, 05:51 PM   #1
350zRomano
Registered User
Thread Starter
 
Join Date: Jan 2018
Location: New York
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Angry 350z Misfire! Nothings working.

I have a 350z 6MT and it is currently throwing a P0300 (Random/Multiple Misfire). I did many things and I cant seem to find the problem. It was recently engine swapped because the old one spun a bearing at 140k. I swapped a G35 ( VQ35DE ) engine in and it was missing. I changed the plugs, the coilpacks, crankshaft position sensor, camshaft position sensor ( driver and passenger side ), changed fuel rail and injectors, changed ignition coil sub harness. I have no idea what to do. Any advice?
350zRomano is offline   Reply With Quote
Old 01-11-2018, 06:46 PM   #2
CK_32
Registered User
iTrader: (1)
 
CK_32's Avatar
 
Join Date: Jan 2016
Location: California
Posts: 3,290
Thanked 322 Times in 276 Posts
Default

Are your injectors leaking?
Are the plugs properly tapped?
Was everything installed correctly?
Was the motor damaged before you got it?
Have you been racing it?
Are there mods on the car?
Have you done a vaccume leak test?
CK_32 is offline   Reply With Quote
Old 01-11-2018, 07:30 PM   #3
350zRomano
Registered User
Thread Starter
 
Join Date: Jan 2018
Location: New York
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

No injectors are good, yes plugs are good, everything was installed correctly, no motor wasnt damaged and did a compression test it was all good aswell. And yes did a vacuum leak test. Im thinking maybe a wiring issue im hoping not
350zRomano is offline   Reply With Quote
Old 01-13-2018, 10:47 AM   #4
bealljk
Registered User
iTrader: (13)
 
Join Date: Apr 2010
Location: col
Posts: 2,633
Thanked 170 Times in 149 Posts
Default

are you 10,000% sure you didnt swap coil plug #6 and #4? They are inherently/logically backwards?

Take a picture of your driver side bank and post it.

Last edited by bealljk; 01-13-2018 at 10:49 AM.
bealljk is offline   Reply With Quote
The Following User Says Thank You to bealljk For This Useful Post:
Cux350z (01-13-2018)
Old 01-13-2018, 03:53 PM   #5
Cux350z
hatersgonnahate
iTrader: (162)
 
Cux350z's Avatar
 
Join Date: Apr 2005
Location: Greenville, SC
Posts: 11,588
Thanked 228 Times in 168 Posts
Default

Quote:
Originally Posted by bealljk View Post
are you 10,000% sure you didnt swap coil plug #6 and #4? They are inherently/logically backwards?

Take a picture of your driver side bank and post it.
this 99% of the time. Nissan makes it too easy!
Cux350z is offline   Reply With Quote
Old 01-14-2018, 12:20 AM   #6
bealljk
Registered User
iTrader: (13)
 
Join Date: Apr 2010
Location: col
Posts: 2,633
Thanked 170 Times in 149 Posts
Default

I know I'm bat-**** crazy ...

Last edited by bealljk; 01-14-2018 at 12:35 AM.
bealljk is offline   Reply With Quote
The Following User Says Thank You to bealljk For This Useful Post:
BluestreamDE (01-14-2018)
Old 01-14-2018, 11:36 AM   #7
MicVelo
350Z/370Z Tech Moderator
MY350Z.COM
 
MicVelo's Avatar
 
Join Date: Oct 2014
Location: Northern California
Posts: 5,440
Thanked 1,456 Times in 1,057 Posts
Default

Quote:
Originally Posted by bealljk View Post
I know I'm bat-**** crazy ...

Yeah, hate to agree with you but I do..... you're the only person I know that owns a V9 Nissan engine. (Or maybe it's a V10 and I just can't see the label on the opposite side.)


MicVelo is offline   Reply With Quote
Old 01-15-2018, 06:18 PM   #8
350zRomano
Registered User
Thread Starter
 
Join Date: Jan 2018
Location: New York
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Red face

thank you my man i appreciate that picture but im almost sure i have them correctly plugged but i will check. Im starting to think its going to come down to a grounding issue.
350zRomano is offline   Reply With Quote
Old Yesterday, 02:23 PM   #9
Cux350z
hatersgonnahate
iTrader: (162)
 
Cux350z's Avatar
 
Join Date: Apr 2005
Location: Greenville, SC
Posts: 11,588
Thanked 228 Times in 168 Posts
Default

coil packs ground with two ring terminals on the front timing cover.
Cux350z is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
350z Misfire?? LowZ33 2003-2009 Nissan 350Z 19 07-15-2017 11:12 PM
2003 350Z Misfire GarniZ33 Maintenance & Repair 30 12-15-2014 10:31 PM
350z misfire cylinder 4 help Black350z9972 Engine & Drivetrain 2 01-25-2014 08:36 PM
I have 1 notifations but nothings there FairLadyz916 Feedback & Suggestions for Our Forum 9 07-21-2010 05:44 PM
350z misfire behaviur! claudio.maras Tuning 4 03-13-2010 03:34 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -8. The time now is 01:17 AM.


Copyright 2002 - 2017, MY350Z.COM All Rights Reserved. We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: