Rear Deroster not turning on. - MY350Z.COM - Nissan 350Z and 370Z Forum Discussion

Notices
Maintenance & Repair 350Z up keep and diagnosing/fixing problems

Rear Deroster not turning on.

Old 01-30-2019, 04:51 AM
  #1  
Bernardo Z33
Registered User
Thread Starter
 
Join Date: Dec 2017
Location: North Carolina
Posts: 92
Thanked 1 Time in 1 Post
Default Rear Deroster not turning on.

Hello everyone. In my Z I was just pressing buttons and noticed my rear defroster does not turn on at all and I never noticed it. When I push the button on the circle it doesent turn on. The little defroster led light doesent come on. Everything else works fine. Is there a fuse or something? Maybe the ribbon cable behind the controls is k
Bernardo Z33 is offline  
Old 01-31-2019, 04:40 PM
  #2  
guitman32
Professional
iTrader: (15)
 
guitman32's Avatar
 
Join Date: Jul 2005
Location: South FL
Posts: 1,948
Thanked 91 Times in 77 Posts
Default

There is a fuse, and the brown relay is in the passenger glove box area, close to the center console bolted vertically to the speaker tower. You have to bend over to see it.

If the fuse is good and you dont hear the relay click, its the relay. Assuming the switch wiring and connections are good of course.
guitman32 is offline  
Old 02-01-2019, 03:56 AM
  #3  
karlt
Registered User
 
Join Date: Dec 2008
Location: Williamsville, NY
Posts: 194
Thanks: 0
Thanked 36 Times in 30 Posts
Default

Bernardo,

You don't give the model year of your car, but I suspect the systems are pretty much the same year to year. My 2005 has 4 fuses; 1 on the fuse block by the driver's foot that provides power to the relay coil, 2 on the IPDM E/R that provide power through the relay contacts to the entire system, and 1 on the fuse block by the driver's foot that provides power from the relay to the outside mirror defrosters. The Service Manual will show you the details. Do your outside mirrors defrost when you turn the system on?

Last edited by karlt; 02-01-2019 at 04:05 AM.
karlt is offline  
Old 02-02-2019, 10:26 AM
  #4  
Bernardo Z33
Registered User
Thread Starter
 
Join Date: Dec 2017
Location: North Carolina
Posts: 92
Thanked 1 Time in 1 Post
Default

Originally Posted by guitman32 View Post
There is a fuse, and the brown relay is in the passenger glove box area, close to the center console bolted vertically to the speaker tower. You have to bend over to see it.

If the fuse is good and you dont hear the relay click, its the relay. Assuming the switch wiring and connections are good of course.
Thank you sir! Will the relay or fuse make the little defroster LED come back on?? Is the fuse located inside next to driver seat or in the engine bay? Also does the clock sound come from the back? If so I donít think it works
Bernardo Z33 is offline  
Old 02-02-2019, 10:27 AM
  #5  
Bernardo Z33
Registered User
Thread Starter
 
Join Date: Dec 2017
Location: North Carolina
Posts: 92
Thanked 1 Time in 1 Post
Default

Originally Posted by karlt View Post
Bernardo,

You don't give the model year of your car, but I suspect the systems are pretty much the same year to year. My 2005 has 4 fuses; 1 on the fuse block by the driver's foot that provides power to the relay coil, 2 on the IPDM E/R that provide power through the relay contacts to the entire system, and 1 on the fuse block by the driver's foot that provides power from the relay to the outside mirror defrosters. The Service Manual will show you the details. Do your outside mirrors defrost when you turn the system on?
Unfortunately I donít have a service manual. If you have a picture do you mind showing me? Itís a 2003 enthusiast. I donít know about the mirrors. I didnít even know they had defrosters. So two fuses next to foot and 2 next to battery?
Bernardo Z33 is offline  
Old 02-02-2019, 11:58 AM
  #6  
dkmura
General & DIY Moderator
MY350Z.COM
iTrader: (62)
 
dkmura's Avatar
 
Join Date: May 2002
Location: Aurora, Colorado
Posts: 6,669
Thanked 656 Times in 457 Posts
Default

Originally Posted by Bernardo Z33 View Post
I donít know about the mirrors. I didnít even know they had defrosters.
None of the '03 Z33 models came with heated mirrors.

dkmura is offline  
Old 02-02-2019, 12:38 PM
  #7  
karlt
Registered User
 
Join Date: Dec 2008
Location: Williamsville, NY
Posts: 194
Thanks: 0
Thanked 36 Times in 30 Posts
Default

Originally Posted by dkmura View Post
None of the '03 Z33 models came with heated mirrors.
Not according to the MY 203 Service Manual.
karlt is offline  
Old 02-02-2019, 12:40 PM
  #8  
karlt
Registered User
 
Join Date: Dec 2008
Location: Williamsville, NY
Posts: 194
Thanks: 0
Thanked 36 Times in 30 Posts
Default

Originally Posted by Bernardo Z33 View Post

Unfortunately I donít have a service manual. If you have a picture do you mind showing me? Itís a 2003 enthusiast. I donít know about the mirrors. I didnít even know they had defrosters. So two fuses next to foot and 2 next to battery?
You can download the Service Manual for your car here:
https://nicoclub.com/archives/nissan...e-manuals.html
You want the gw.pdf section for your particular issue.
karlt is offline  
Old 02-02-2019, 02:52 PM
  #9  
guitman32
Professional
iTrader: (15)
 
guitman32's Avatar
 
Join Date: Jul 2005
Location: South FL
Posts: 1,948
Thanked 91 Times in 77 Posts
Default

Originally Posted by Bernardo Z33 View Post

Thank you sir! Will the relay or fuse make the little defroster LED come back on?? Is the fuse located inside next to driver seat or in the engine bay? Also does the clock sound come from the back? If so I donít think it works
to karltís point there are actually multiple fuses...i was referring to the higher amperage supply for the relay to power the defroster coil. There is a second that powers the low amp trigger. To be honest i never bothered locating the fueses when stripping the car i just removed the relay and de-wired it. Im mobile atm but the fsm should help you.
guitman32 is offline  
Old 02-02-2019, 02:55 PM
  #10  
guitman32
Professional
iTrader: (15)
 
guitman32's Avatar
 
Join Date: Jul 2005
Location: South FL
Posts: 1,948
Thanked 91 Times in 77 Posts
Default

Oh and the click comes from the relay itself.
guitman32 is offline  
Old 02-02-2019, 04:06 PM
  #11  
dkmura
General & DIY Moderator
MY350Z.COM
iTrader: (62)
 
dkmura's Avatar
 
Join Date: May 2002
Location: Aurora, Colorado
Posts: 6,669
Thanked 656 Times in 457 Posts
Default

Originally Posted by karlt View Post
Not according to the MY 203 Service Manual.
OK- but the '03 Nissan service manual shows only motors for the outside mirrors. No heater installed in either side according to GW83-85. Can you point towards another schematic that shows something different?
dkmura is offline  
Old 02-02-2019, 05:16 PM
  #12  
guitman32
Professional
iTrader: (15)
 
guitman32's Avatar
 
Join Date: Jul 2005
Location: South FL
Posts: 1,948
Thanked 91 Times in 77 Posts
Default

Wow I just checked the fsm...the rear defogger system is super complicated. I count 7 fuses.
guitman32 is offline  
Old 02-03-2019, 05:03 AM
  #13  
karlt
Registered User
 
Join Date: Dec 2008
Location: Williamsville, NY
Posts: 194
Thanks: 0
Thanked 36 Times in 30 Posts
Default

Originally Posted by dkmura View Post
OK- but the '03 Nissan service manual shows only motors for the outside mirrors. No heater installed in either side according to GW83-85. Can you point towards another schematic that shows something different?
Look at GW67 - 70.
karlt is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
D15na
Audio & Video
0
04-29-2008 01:25 PM
KManZ
Audio & Video
22
01-22-2008 08:42 AM
travism30
Audio & Video
7
09-17-2007 07:07 PM
ColecatZ
2003-2009 Nissan 350Z
14
11-18-2002 06:16 AM


Thread Tools
Search this Thread
Quick Reply: Rear Deroster not turning on.


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: